System requirements for using Brosix

What are the system requirements for using Brosix?
Brosix can be installed on an USB flash drive and you can take it with you and use on any computer.
  • Windows 10, Windows 8, Windows 7 / Vista / XP / 2008 / 2003
  • Linux – Ubuntu / Fedora
  • Mac OS X Lion / Snow Leopard / Leopard
  • 128 MB RAM
  • 50 MB disk space
  • 800 MHz CPU or higher
  • Internet connection