Brosix System Requirements

Brosix System Requirements

What are the system requirements for using Brosix?

Brosix can be used on virtually any platform used today.

Desktop – Windows, Mac and Linux

Brosix runs on any computer with these parameters:

  • Windows 8 / 7 / Vista / XP / 2008 / 2003
  • Mac OS
  • Linux
  • 512 MB RAM
  • 100 MB disk space
  • 800 MHz CPU or higher
  • Internet connection

Android

Brosix runs on any mobile device (tablets and phones) with Android:

  • Android 2.2 and newer versions
  • Internet connection – Wi-Fi, 3G, 4G, LTE

iPhone, iPad, iPod touch

Brosix runs on any mobile device (tablets and phones) with iOS

  • iOS 6.0 and newer versions
  • Internet connection – Wi-Fi, 3G, 4G, LTE